centos6安装fpm究极版

2018-05-18 分类:实用技能 阅读(1842) 评论(0)

本文只讲安装,关于使用fpm请访问http://blog.oldboyedu.com/autodeploy-rpm/

 

前言:最近在centos6上用gem安装fpm总算失败,查阅了大量文章都无效,最终灵机一动才解决,于是草草记录下来!

 

1:安装ruby环境

由于fpm是使用ruby开发的,首先安装ruby环境

yum -y install ruby rubygems ruby-devel

 

2:更换Ruby Gems源

这里我选用清华大学的源,这个是最全的国内镜像源

gem sources --add https://mirrors.tuna.tsinghua.edu.cn/rubygems/ --remove http://rubygems.org/

验证:

gem sources -l

 

3:使用gem安装fpm

gem install fpm

如果出现以下报错

请先安装gcc编译器

yum install gcc gcc-c++ glibc -y

 

再次执行安装

[root@m01 ~]# gem install fpm

Building native extensions. This could take a while...

ERROR: Error installing fpm:

    ffi requires Ruby version >= 1.9.

出现这个报错,是因为fpm最新版只支持centos7,对于centos6只能使用旧版的fpm

但是fpm有哪些旧版本呢??

可以通过官网https://rubygems.org/gems查询

这里我查询到fpm 1.4.0版是2015年最后更新的一个版本

这里我们安装指定版本的fpm

再次执行安装fpm

[root@m01 ~]# gem install fpm -v 1.4.0

ERROR: Error installing fpm:

    ffi requires Ruby version >= 1.9.

还是提示这个报错,看来fpm依赖的ffi默认也是安装最新版,这里我们手动安装下ffi的旧版本,查看官网2015年最后的一个ffi版本是1.9.10

于是我们先安装ffi 1.9.10

gem install ffi -v 1.9.10

安装成功ffi旧版后,再次执行安装fpm 1.4.0

[root@m01 ~]# gem install fpm -v 1.4.0

Successfully installed childprocess-0.9.0

Successfully installed fpm-1.4.0

2 gems installed

Installing ri documentation for childprocess-0.9.0...

Installing ri documentation for fpm-1.4.0...

Installing RDoc documentation for childprocess-0.9.0...

Installing RDoc documentation for fpm-1.4.0...

 

到这里centos6 安装fpm成功!

关于fpm的使用详情,请访问http://blog.oldboyedu.com/autodeploy-rpm/

评论已关闭

登录

忘记密码 ?

切换登录

注册